My hard disk is seemingly FUBAR
08-23-2015, 02:56 PM,
Post: #1
My hard disk is seemingly FUBAR
So I've been using Boot Camp for the last little while, and, naturally, something was screwed up in Windows. Since nothing I did seemed to resolve it, I decided to restore my Boot Camp partition from a backup I made using software called Boot Camp Backup.

Of course, restoring from the backup failed miserably, but it seems to have messed up more than just the Windows partition. When the operation failed, I thought, fine, I'll just wipe the Boot Camp partition entirely with Boot Camp Assistant and start over…give myself the full Windows experience, if you will. Would have worked, except the partition was gone. Nothing left but an empty, unallocated crater of space on my disk. Boot Camp Assistant was only seeing about 880 GB of my 1 TB disk (I'm sure you've guessed by now the Boot Camp partition was 120 GB). I should also mention I'm using FileVault on the Mac; I've been using it now for about the past year, and have never had any problems with it whatsoever. I've removed and readded the Boot Camp partition several times without incident.

No problem, I thought. Just head into Disk Utility and see what's happening. There it was: my disk showing the 880 GB of my OS X partition, and 120 GB unallocated free space. Couldn't resize my OS X partition, so I thought I'd just recreate a 120 GB FAT partition. No go: progress bar appeared for a split second and disappeared entirely. Nothing was properly repartitioned.

Okay, fine…I'm reasonably smart here; let's see how else I can get it back. Attempted to boot to recovery partition…couldn't. No worries; that's why I've got installers of every version of OS X that'll run on this Mac on an external drive. Booted to the Yosemite installer, opened Disk Utility, and it couldn't unmount my internal disk to erase and repartition it as one disk. By this point, I'm getting very aggravated, but still with some ideas. I think what finally got things working again was booting the iMac to target disk mode, connecting via Thunderbolt to my MacBook Air, and using Disk Utility there to format the sucker (after force-unmounting the disk via Terminal). Good. Boot to the installer, reinstall Yosemite, then restore from my Time Machine backup (how many times has that thing saved my ass?).

By the time I've got everything working properly again on my Mac, I'm ready to try to reinstall Windows again. Boot Camp Assistant seemingly repartitioned the drive properly, and I booted to the install DVD I created. Got to the point of choosing my partition for installing, and attempted reformatting the FAT partition as NTFS, and the Windows installer had a shit fit. Nope, sorry, can't install there, not a valid partition. Whaaa…? Fine…I give up. Back to OS X to remove the partition and try again. Oddly enough, Disk Utility showed the partition had been reformatted as NTFS…weird. Off to Boot Camp Assistant to remove the partition and try again. About 3/4 of the way through, Boot Camp Assistant threw up an error saying the process couldn't be completed. Come on! This is after spending about an hour or two to get the drive reformatted in the first place and two evenings restoring my data (would have been one, but, admittedly, I screwed up one portion of it).

So now, I think the disk is rightly fucked. I thought, if anything, reformatting though target disk mode should solve this, and yet I'm back at the same place I was three days ago. My next thought is to try and get Windows installed on one of my external drives to see if it has any better luck repartitioning the internal drive (oddly enough, reformatting through Windows was how I got a drive I couldn't get to mount at all on any of the three Macs in the household back up and running). Unless, of course, anyone has some other thoughts?
08-23-2015, 07:17 PM, (This post was last modified: 08-23-2015, 07:18 PM by FuturDreamz.)
Post: #2
RE: My hard disk is seemingly FUBAR
Did you try deleting all partitions in the windows installer, and let it automatically make it's own partitions?

The other thing I guess would be to boot a mac installer to launch Disk Utility, and switch the disk to MBR and back. It may also have some more advanced erasing and disc verification features, but it's been a while since I used it last.
My logic is infallible. Resistance is futile.
08-25-2015, 04:56 AM,
Post: #3
RE: My hard disk is seemingly FUBAR
Okay, so here's what I've done today:
  • Turned off FileVault on the iMac and allowed it to fully decrypt the disk.
  • Booted to Mountain Lion on my MacBook Air. The Air is running El Cap PB, and I don't like its Disk Utility for managing partitions. Thought I'd try ML for a change. Booted iMac to target disk mode and connected via Thunderbolt. Tried to repartition iMac's internal drive as one whole, but got the same "can't unmount" error as before. Headed to Terminal to force unmount the partition…kernel panic. Enough of that.
  • Booted to Yosemite installer on the Air. iMac still connected via Thunderbolt. Force unmounted iMac's internal drive via Terminal and returned to Disk Utility. Set up to repartition as one drive using MBR partition map. Success. Set partition map back to GPT and reformatted disk. Success.
  • Booted to Windows 10 install DVD with SuperDrive connected to MacBook Air. Realized it was goofy to expect it to see the iMac over Thunderbolt, but realized it was more goofy that Windows can't install to an external drive at all, not even the partition I'd set up on an external USB hard disk. Argh.
  • Restarted iMac; booted to Windows 10 install DVD from internal SuperDrive. Deleted HFS+ partition from internal drive and let Windows do its thing to format and partition the disk.
  • Quit Windows installer. Reboot to Yosemite install partition on external drive. Repartitioned iMac's internal disk as one HFS+ partition, with GPT. Reinstalled Yosemite.
The iMac is currently rebooting, but here are my next steps:
  • Set up as new; don't restore from the Time Machine backup yet.
  • Use Boot Camp Assistant to attempt to set up 120 GB partition for Windows.
  • Boot from Windows 10 Install DVD and attempt to install Windows onto new partition.
  • If successful, boot to Yosemite installer and restore from Time Machine backup.
  • Take pride in my ingenuity and resourcefulness.
08-25-2015, 04:23 PM,
Post: #4
RE: My hard disk is seemingly FUBAR
This is as far as I got:
(08-25-2015, 04:56 AM)Skippy Wrote:
  • Boot from Windows 10 Install DVD and attempt to install Windows onto new partition.
And I think I figured it out. I questioned why my iMac wasn't included in the list of supported Macs for Boot Camp 6.0, which builds in support for Windows 10; I thought it was just a driver thing, but there may be more to it. If I'm understanding what I've read correctly (that's a big if), Windows 10 requires the partition scheme to be GPT only; Boot Camp 5.x on my iMac, I presume to maintain compatibility with 32-bit versions of Windows, uses a hybrid scheme that allows the Boot Camp partition to live in a little MBR world in the greater GPT universe of the entire disk. When I upgraded my install of Windows 7 to Windows 10, Windows must have done something that buggered up that little world, and that was exacerbated by me trying to restore the Win10 backup that Boot Camp Backup made. That would also explain why the Windows 10 installer refused to install in the freshly formatted NTFS partition I gave it: it was still seeing that MBR-within-GPT world that Apple built for compatibility sake, and knew it couldn't work, so it threw up the error. Windows 7 installed just fine.

Since I'd still like to have Windows available to me (guess I'm a masochist or something), I'm going to see if there's a non-Apple-sanctioned, non-Boot Camp Assistant way of doing this. I'm presuming there shouldn't be any issue with me removing the Boot Camp partition, adding a 120 GB FAT partition using Disk Utility, and then using the Windows 10 installer to delete said partition and recreate everything it needs in that 120 GB space. If not, I know how to get Win10 installed over my Win7 install, and how to fix things if they get buggered up again.
08-26-2015, 05:35 AM,
Post: #5
RE: My hard disk is seemingly FUBAR
A massage doesn't always have to lead to sex, but if it doesn't then you're doing it wrong.
flickr | Stupid Blog | Twitter

Forum Jump: